Newly acquired DTFs dying is it red leg?

A big issue both in enclosures and in the wild.

Moderators: Chris Key, Gerry Marantelli, Mod Squad

Michigan
tadpole
tadpole
Posts: 48
Joined: Thu Mar 01, 2012 4:45 pm
Location: NSW

Newly acquired DTFs dying is it red leg?

Postby Michigan » Sun Mar 24, 2013 8:46 pm

Hi two weeks ago I bought 3 male Littoria Fallax at the NSW Penrith Reptile Show, I've had my frogs in a quarantine tank but 2 of them have died in the past four days, they showed no sign of illness, were healthy eaters - feeding on extra small crickets (dusted with calcium powder every second feed).
Their water was changed daily & treated with Repti Safe. What could be the problem?
Am having trouble attaching photos, will post them asap.

Michigan
tadpole
tadpole
Posts: 48
Joined: Thu Mar 01, 2012 4:45 pm
Location: NSW

red leg? photos

Postby Michigan » Mon Mar 25, 2013 6:11 pm

Here are the photos of my Littoria Fallax.
Any Thoughts or help appreciated.
Thank you
Attachments
DTF 3a.jpg
DTF 2a.jpg
DTF 1a.jpg

Michigan
tadpole
tadpole
Posts: 48
Joined: Thu Mar 01, 2012 4:45 pm
Location: NSW

Postby Michigan » Thu Mar 28, 2013 12:40 pm

Please can anyone help me??? My third frog is dead now too.

Michigan
tadpole
tadpole
Posts: 48
Joined: Thu Mar 01, 2012 4:45 pm
Location: NSW

Postby Michigan » Fri Mar 29, 2013 6:21 pm

Thank you so much, that means alot :)

Sean
frog
frog
Posts: 183
Joined: Thu Jan 13, 2011 11:38 am

Postby Sean » Sat Mar 30, 2013 11:20 am

Sorry to hear that as well. I am not sure what the problem would be.

I'm guessing all your other frogs are okay? Then they might have been infected with a disease when you bought them.

Another thing to consider might be the quarantine tank itself. Did you disinfect it before putting them in there? If you did, maybe some of the disinfectant remained? I you didn't then they might have been infected from the tank itself? Just some ideas, not saying they are likely the cause.

Frog Safe might be able to help you a bit more:

http://www.frogsafe.org.au/contact/

Michigan
tadpole
tadpole
Posts: 48
Joined: Thu Mar 01, 2012 4:45 pm
Location: NSW

Postby Michigan » Sat Mar 30, 2013 1:23 pm

Thanks Sean, I'm sure I rinsed the quarantine tank thoroughly after I used reptikleen to disinfect it, it had been a while since I had anything in it. Thanks for the link I'll check it out.


Return to “Health and disease”

Who is online

Users browsing this forum: No registered users and 1 guest